-
Bug
-
Resolution: Fixed
-
P2
-
1.0.2
-
None
-
1.2beta4
-
generic
-
generic
-
Not verified
BasicMenuUI.MouseListener should be renamed to something else. Naming the inner class MouseListener hides java.awt.event.MouseListener. Uninintentional consequesnces:
- protected mouseListener field is of type BasicMenuUI.MouseListener, not java.awt.event.MouseListener
- protected method createMouseListener is not overridable b/c the return type is BasicMenuUI.MouseListener (which is neither public nor protected)
- protected mouseListener field is of type BasicMenuUI.MouseListener, not java.awt.event.MouseListener
- protected method createMouseListener is not overridable b/c the return type is BasicMenuUI.MouseListener (which is neither public nor protected)