Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4445219

JNI issue: overloading the global operator delete in the hotspot VM

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2
    • Resolution: Not an Issue
    • Affects Version/s: 1.3_01
    • Fix Version/s: None
    • Component/s: hotspot
    • Subcomponent:
    • CPU:
      sparc
    • OS:
      solaris_2.6

      Description

      cu is having a JNI application and the delete operator is not overloading properly. JDK version is 1.3.0. C++ version is Forte 6.0 update 1.

      The procedure for reproducing the problem is follows and the files are in the attachments:

      o build the test case:

      1. Compile the java source - OpDelete.java
      2. Create a shared library named "libopdelete.so" from OpDelete.cpp. Files 4
      and 5 might help in doing that.

      Javah was run on on the classfile and the resulting OpDelete.h is attached. So
      you will not need to generate that file.

      To run the test case:

      1. Put libopdelete.so is in your LD_LIBRARY_PATH
      2. Put OpDelete.class in your classpath.
      3. execute "java OpDelete"

      If java 1.3 with a hotspot VM is used, then the following message is printed
      out:

        "our delete operator was NOT called."

      If any non-hotspot VM is used or if the shared library is built using SC 4.2
      (compat mode), then the following message is printed out:

        "our delete operator was called."

        Attachments

          Activity

            People

            Assignee:
            collins Gary Collins (Inactive)
            Reporter:
            srmantha Srinivas Mantha (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: