Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-6516845

Installation issues with u10 on IE java.com

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: 5.0u10
    • Fix Version/s: 5.0u11
    • Component/s: deploy
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b03
    • CPU:
      x86
    • OS:
      windows_xp

      Backports

        Description

        I and others have been experiencing issues with trying to update from u9 to u10 on java.com on IE on Win XP.

        Here are some details on issues found:

        Scenario 1:
        Initiated download, pressed activex bar and installer came up, then the installer
        disappeared, then the java.com page after about 20 seconds redirected to the
        installation verification page where it told me I had u9 not the latest.

        Scenario 2:
        Attempt #1. Already had u10 installed and when going to java.com->begin download...nothing happens, no messages, no installer, nothing that says I already have u10, etc.

        Attempt #2. I uninstalled u10 first, then did the java.com->begin download, got the activex bar, etc. Installed fine, installer finished, but did not get redirected to verification page or anything.

        Manually went to verification page whereupon it bogged thru the first test, then went to second test before coming up with large applet window w/ messaging saying congrats I have latest installed. This messaging took minutes to come up.

        Attempt #3. Now that I had u10 installed, went back to java.com->begin download and again nothing happens. No installer nor any messaging.

        Scenario 3 and Omniture info (from Lauren):
        http://java.com/en/
        I have four Windows XP -SP2 machines using IE. They have Update 9 loaded. Here is what happened:
        1. I restarted the computer, then went to http://java.com/en/ and selected Download Now.
        2. This took me to http://www.java.com/en/download/windows_ie.jsp. I selected Begin Download.
        3. The yellow bar asking me to accept Active X came up (along with the warning on our java.com page http://www.java.com/en/download/windows_ie.jsp?begindownload=true). I accepted Active X, and the Installation window came up. I select Install. (so far, so good)
        4. But then no other installation screens came up and the browser went to http://java.com/en/download/installed.jsp. I also noticed that at this time the java icon appeared in the bottom right tray. (It was definitely NOT on before I select Install on the last step.)
        5. I tried to Verify Installation, but as expected, I had Update 9, not Update 10.

        This sequence of events happened on 3 of my 4 computers. The 4th one usually doesn't display the Active X warning (for some reason it usually successfully installs without it) and didn't bring up the Installation screen at all, but did send me straight to the verify page.

        This path is hard to measure in Omniture since we can't tie the installation to the java.com screens, but there is strong indication that others are having this or similar problems. I attached two charts showing changes in the paths people take to download the JRE and then check to see if they have the latest version. The two date ranges I used were December 1-17, 2006 for pre-Update 10 and January 1-17, 2007 for post-Update 10.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                ccheung Calvin Cheung
                Reporter:
                duke J. Duke (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: