Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7172937

update plugin/webstart auto-install logic to handle JavaFX co-bundle

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • P2
    • Resolution: Fixed
    • 7u6
    • 8
    • deploy
    • 7u6
    • b43
    • generic
    • generic
    • Verified

    Backports

      Description

        Starting in JRE 7u6 and FX 2.2 - we will support JavaFX on win, linux and macos. Also, there will be both cobundle install and standalone install on windows.

        We need to update plugin/webstart FX auto-install logic to handle all these new scenarios.

        e.g: application request: Jre=6+ fx=2.2

        on windows, should we download the 7u6 co-bundle ? or should we download the standalone fx installer ?

        we need to update our logic to handle these cases.

        Attachments

          Issue Links

            Activity

              People

                ngthomas Thomas Ng (Inactive)
                ngthomas Thomas Ng (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved:
                  Imported:
                  Indexed: