Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8033180

An inappropriate newline symbol in the help section

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P5
    • Resolution: Fixed
    • Affects Version/s: 8
    • Fix Version/s: 9
    • Component/s: tools
    • Environment:

      8.0 b126

    • Subcomponent:
    • Resolved In Build:
      b03
    • Verification:
      Verified

      Backports

        Description

        Several lines of the help section are separated by "0A" new line symbol that does not correspond to the OS (should be "0D 0A" for Windows).

        Usage: javap <options> <classes>
        where possible options include

        55 73 61 67 65 3A 20 6A 61 76 61 70 20 3C 6F 70
        74 69 6F 6E 73 3E 20 3C 63 6C 61 73 73 65 73 3E
        0A 77 68 65 72 65 20 70 6F 73 73 69 62 6C 65 20
        6F 70 74 69 6F 6E 73 20 69 6E 63 6C 75 64 65

        -package Show package/protected/public classes
                                   and members (default)

        -sysinfo Show system info (path, size, date, MD5 hash)
                                   of class being processed

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                jjg Jonathan Gibbons
                Reporter:
                ogb Oleg Barbashov (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: