Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8041123

DRS: messaging is incorrect when blocking due to DRS version mismatch

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 7u40, 8
    • Fix Version/s: 8u20
    • Component/s: deploy
    • Labels:
      None
    • Resolved In Build:
      b15

      Backports

        Description

        When the deployment rule for an application requires a version that is not the latest installed, and does not match the version requested by the app, The application will block as is expected, however the dialog says (for example where application has requested "1.8+" and DRS requires "1.7*):

        title: "Application Blocked by Deployment Rule Set" (correct)
        reason: "Deployment Rule Set required version 1.7* not available" (not correct)

        The reason the app is blocking is not that 1.7* is not available, but that it doesn't match the version specified by the application.

        we need to change the text of the reason to better indicate why we are blocking.

        This does not apply to DRS version 1.1 when new force attribute is set to true, but applies to version 1.0 or 1.1 when force attribute is false.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                herrick Andy Herrick (Inactive)
                Reporter:
                herrick Andy Herrick (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Due:
                  Created:
                  Updated:
                  Resolved: