Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8042571

Cannot run FX applets if Java 7 and 8 are installed and Java 8 is disabled via JCP

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 8u5
    • Fix Version/s: 8u20
    • Component/s: deploy
    • Labels:
      None
    • Resolved In Build:
      b16
    • OS:
      windows

      Backports

        Description

        Cannot run FX applets in Java 7 and 8 install and Java 8 is disabled via JCP.

        Follow steps from https://bugs.openjdk.java.net/browse/JDK-8028644.
        1) Install JRE 8u5
        2) Install JRE 7u55
        3) Disable JRE 8u5 via JCP on Java tab.
        4) Run http://download.oracle.com/otndocs/products/javafx/2/samples/Ensemble/index.html

        Note: I tried several more FX applets and non of then works.
        Browser will give error:
        JavaFX application could not launch due to system configuration (show error details). See java.com/javafx for troubleshooting information.

        Reproducible on Windows 7 with IE, Firefox and Chrome. Did not tried on other platforms.

        Java.com and AWT applets seems to work fine in this configuration.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                almatvee Alexander Matveev
                Reporter:
                almatvee Alexander Matveev
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: