Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8061257

nashorn ant build script should have a sanity target

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: core-libs
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b37
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        The nashorn's ant build script does not check for any versions of the required tools
        or the platforms.

        There ought to be a "sanity" target which will demand a particular version
        of ant, java etc. etc. to be used along for performing the build, this will make it
        easier for other people to build and test nashorn, avoid guessing of cryptic error
        message.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                sundar Sundararajan Athijegannathan
                Reporter:
                ksrini Kumar Srinivasan
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: