Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8094218

Allow Windows MSI Bundler productVersion to differ from the general version

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 8u20
    • Fix Version/s: 8u20
    • Component/s: deploy
    • Labels:
      None

      Description

      Currently the version of a MSI bundle must be the same version used for other bundlers, such as the EXE bundler. The problem is that MSI requires a very restrictive numbering format of "1.2.3" whereas sometimes a more liberal versioning scheme is useful, such as "1.2.3_beta_win32_20140604_debug".

      We will introduce a bundler argument "win.msi.productVersion" that can be set to the shorter version, and the default will be to use the version for the whole build. This version will continue to be validated.

        Attachments

          Activity

            People

            Assignee:
            shemnon Danno Ferrin (Inactive)
            Reporter:
            shemnon Danno Ferrin (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Imported: