Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8097778

isIdeographic missing on Android < api level 19

    XMLWordPrintable

    Details

      Description

      Android devices with API level < 19 (thus before kitkat = 4.4) don't have Character.isIdeographic.
      There is only 1 place in the OpenJFX repository where this method is called.
      The patch at https://bitbucket.org/javafxports/8u60-rt/commits/cf75a074ab7ed8ffaf5a1e044b29057deaf0ea5d/raw/ detects if the runtime has Character.isIdeographic, and will use it when available, otherwise ignore it.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kcr Kevin Rushforth
              Reporter:
              jvos Johan Vos
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Imported: