Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8124922

TableView.TableViewSelectionModel changes in Lombard are not back compatible with previous versions

    XMLWordPrintable

Details

    Description

      Changes to the public api in TableView.TableViewSelectionModel are not back compatible with previous releases. Specifically, the change in return type for getSelectedCells() and isSelected() break back compatibility. Additionally, the protected method getTableModel() has been removed entirely.

      For an example, see https://github.com/james-d/Conditionally-selectable-table (which was also referenced in the OTN discussion at https://forums.oracle.com/forums/thread.jspa?threadID=2539110&tstart=0). This example compiles under JavaFX 2.2.7 and JDK 1.7.0_21, but will not compile under JavaFX 8.0 (JDK 1.8.0 ea b90). Additionally, and more importantly, the compiled code from JavaFX 2.2.7/JDK 1.7.0_21 runs under the same JDK, but fails to run under JDK 1.8.0 ea b90.

      This is related to RT-29175

      Attachments

        Activity

          People

            jgiles Jonathan Giles
            jdenvirjfx James Denvir (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              Imported: