Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8150511

LSMinimumSystemVersion set incorrectly

    XMLWordPrintable

    Details

    • Subcomponent:
    • CPU:
      x86
    • OS:
      os_x

      Description

      FULL PRODUCT VERSION :


      ADDITIONAL OS VERSION INFORMATION :
      All Mac OS Versions

      A DESCRIPTION OF THE PROBLEM :
      The java system requirements page lists Mac OS X 10.8.3+ as being required for java 8, but the app generated by javapackager sets LSMinimumSystemVersion to 10.7.4. Updating the setting would allow users to see a sensible error when attempting to open the application.

      STEPS TO FOLLOW TO REPRODUCE THE PROBLEM :
      - Package an application for mac using javapackager with -native dmg
      - Inspect the resulting mac application's Info.plist


      EXPECTED VERSUS ACTUAL BEHAVIOR :
      EXPECTED -
      In following the above steps, I expect to see LSMinimumSystemVersion as 10.8.3.
      ACTUAL -
      I see LSMinimumSystemVersion as 10.7.4

      REPRODUCIBILITY :
      This bug can be reproduced always.

      CUSTOMER SUBMITTED WORKAROUND :
      This can be worked around by packaging the files generated for javapackager with a different (correct) Info.plist instead of the one generated by javapackager.

        Attachments

          Activity

            People

            Assignee:
            cbensen Chris Bensen (Inactive)
            Reporter:
            webbuggrp Webbug Group
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: