Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8161696

[TESTBUG] runtime/StackGuardPages/testme.sh uses invalid argument -Xss328k

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 9
    • Fix Version/s: 9
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
    • Resolved In Build:
      b133

      Description

      The stack size specified is too small, Specify at least 384k
      Test started with pid: 86114

      From Dan D:

      hotspot/test/runtime/StackGuardPages/exeinvoke.c:

        options[0].optionString = "-Xint";
        options[1].optionString = "-Xss328k";
        options[2].optionString = javaclasspathopt;

        vm_args.version = JNI_VERSION_1_2;
        vm_args.ignoreUnrecognized = JNI_TRUE;
        vm_args.options = options;
        vm_args.nOptions = 3;

        if (JNI_CreateJavaVM (&_jvm, (void **)&env, &vm_args) < 0 ) {
          fprintf(stderr, "Test ERROR. Can't create JavaVM\n");
          exit(7);
        }

      Don't know where that magic "-Xss328k" came from, but it's
      not going to work on a platform (ARM64) that requires 384K.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gthornbr Gerald Thornbrugh (Inactive)
              Reporter:
              jprovino Joseph Provino (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: