Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8011044 Remove support for 1.5 and earlier source and target options
  3. JDK-8173720

Release Note: Remove support for 1.5 and earlier source and target options

    XMLWordPrintable

    Details

    • Subcomponent:
    • Verification:
      Verified

      Description

      The `javac` command no longer supports `-source` or` -target` values for releases before 6/1.6. However, older class files are still readable by `javac`. Source code for older release can be ported to a newer source level. To generate class files usable by releases older than JDK 6, a `javac` from a JDK 6, 7, or 8 release family can be used.

      [JEP 182](http://openjdk.java.net/jeps/182) documents the policy for retiring old `-source` and `-target` options.

        Attachments

          Activity

            People

            Assignee:
            darcy Joe Darcy
            Reporter:
            rcalnan Roger Calnan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: