Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8202556

Support pre-1.5 classes in CDS

    XMLWordPrintable

Details

    • Enhancement
    • Status: Closed
    • P4
    • Resolution: Won't Fix
    • 10, 11
    • 12
    • hotspot

    Description

      Pre-1.5 classes are disabled during CDS dump time:

      http://hg.openjdk.java.net/jdk/jdk/file/450d709262c1/src/hotspot/share/classfile/classFileParser.cpp#l5916

      because in some cases, the pre-1.5 verification would need to execute Java code (to do some sort of rather mundane string encoding conversion ??). This used to a bad thing because we wanted to avoid executing Java code at dump time. However, now that we are using the Java class loaders anyway during dump time (since JDK 10), it seems no longer necessary to enforce this.

      NOTE: we need to check if class constraint support can be support for these classes.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              iklam Ioi Lam
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: