Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8202863

Rename OopStorage inner collection classes

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 11
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
      gc
    • Resolved In Build:
      b15
    • CPU:
      generic
    • OS:
      generic

      Backports

        Description

        During the review for JDK-8200557 it was suggested that some private inner classes of OopStorage should be renamed, to be less generic and more accurately reflect their purpose. Specifically, the following name changes should be made:

        BlockArray => ActiveArray
        BlockList => AllocateList
        BlockEntry => AllocateEntry

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                kbarrett Kim Barrett
                Reporter:
                kbarrett Kim Barrett
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: