Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8210382

Obsolete EmitSync

    XMLWordPrintable

    Details

    • Type: CSR
    • Status: Closed
    • Priority: P4
    • Resolution: Withdrawn
    • Fix Version/s: 12
    • Component/s: hotspot
    • Labels:
      None
    • Subcomponent:
    • Compatibility Kind:
      behavioral
    • Compatibility Risk:
      low
    • Compatibility Risk Description:
      The flag is experimental, and documented as "(Unsafe, Unstable)". There does not seem to be any mention of it on the net.
    • Interface Kind:
      add/remove/modify command line option
    • Scope:
      Implementation

      Description

      Summary

      Obsolete the EmitSync flag.

      Problem

      The experimental EmitSync flag can in theory be used to select which implementation of the synchronization primitives to use. The flag was convenient when the various implementations were compared a long time ago.

      In practice the only implementation that is used and tested today is the default one. The EmitSync flag no longer serves the purpose it used to, and is "Unsafe, Unstable" (the documentation of the flag says so explicitly). It should be obsoleted and later removed.

      Solution

      The EmitSync flag should be obsoleted.

      Specification

      The EmitSync flag will be obsoleted by adding it to the special flags table in arguments.cpp:

      diff -r 091d35929686 src/hotspot/share/runtime/arguments.cpp
      --- a/src/hotspot/share/runtime/arguments.cpp   Tue Sep 04 10:04:14 2018 -0700
      +++ b/src/hotspot/share/runtime/arguments.cpp   Tue Sep 04 10:17:30 2018 -0700
      @@ -574,6 +574,7 @@
         { "PrintSafepointStatisticsCount", JDK_Version::jdk(11),     JDK_Version::jdk(12), JDK_Version::jdk(13) },
         { "TransmitErrorReport",           JDK_Version::undefined(), JDK_Version::jdk(12), JDK_Version::jdk(13) },
         { "ErrorReportServer",             JDK_Version::undefined(), JDK_Version::jdk(12), JDK_Version::jdk(13) },
      +  { "EmitSync",                      JDK_Version::undefined(), JDK_Version::jdk(12), JDK_Version::jdk(13) },
      
       #ifdef TEST_VERIFY_SPECIAL_JVM_FLAGS
         { "dep > obs",                    JDK_Version::jdk(9), JDK_Version::jdk(8), JDK_Version::undefined() },

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mikael Mikael Vidstedt
              Reporter:
              mikael Mikael Vidstedt
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: