Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8246044

ZGC: Rename ZDirector's max_capacity to soft_max_capacity

    XMLWordPrintable

Details

    • Enhancement
    • Status: Resolved
    • P4
    • Resolution: Fixed
    • 15
    • 15
    • hotspot
    • gc
    • b26

    Description

      After JDK-8222182, ZDirector started to use the "soft max capacity" to guide its heuristics. However, a number of local variables are still called max_capacity. I propose we rename them soft_max_capacity for clarity.

      Attachments

        Activity

          People

            pliden Per Liden (Inactive)
            pliden Per Liden (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: