Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8267163

Rename anonymous loader tests to hidden loader tests

    XMLWordPrintable

Details

    • b16

    Backports

      Description

        Test directory test/hotspot/jtreg/vmTestbase/vm/mlvm/anonloader should be renamed to something like test/hotspot/jtreg/vmTestbase/vm/mlvm/hiddenloader because its tests are for hidden classes, not unsafe anonymous classes. Additionally, files AnonkTestee01.java AnonkTestee02 could be renamed to HiddenTestee... Note that this renaming would requiring changing test package names and their references to AnonkTestee...

        Also, some gc tests, such as unloading_anonclassloader_inMemoryCompilation_keep_obj/TestDescription.java should also be renamed.

        Attachments

          Issue Links

            Activity

              People

                mseledtsov Mikhailo Seledtsov
                hseigel Harold Seigel (Inactive)
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved: