Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8270314

TreeTableCell: inconsistent naming for tableRow and tableColumn property methods

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: 8, openjfx16
    • Fix Version/s: openjfx17
    • Component/s: javafx
    • Labels:

      Backports

        Description

        In TreeTableCell there is a mismatch between name of the following property method vs the getter:

          tableRowProperty()
          getTreeTableRow()

        the get method has "Tree" in the name while the property method does not.

        Note that the corresponding methods for column are self-consistent, and are named without the "tree" in the name:

              tableColumnProperty()
              getTableColumn()

        the docs are on a private field that *does* have tree in the name so there are no docs generated for the property.

        Loosely related: the update methods for both row and column use "TreeTable" in the name:

            updateTreeTableColumn​()
            updateTreeTableRow​()

        Once we figure out how to remedy this, we will need to deprecate the misnamed methods and add new methods with the correct name. We probably wouldn't deprecate the misnamed methods for removal (at least not right away), to give applications a better transition path.

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                kcr Kevin Rushforth
                Reporter:
                kcr Kevin Rushforth
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: