Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8276790

Rename GenericCDSFileMapHeader::_base_archive_path_offset

    XMLWordPrintable

Details

    • Enhancement
    • Status: Resolved
    • P4
    • Resolution: Fixed
    • None
    • 18
    • hotspot
    • b23

    Description

      https://github.com/openjdk/jdk/blob/884915496f7bfe754279f1644603131c64f192b3/src/hotspot/share/include/cds.h#L70

      Both "path" and "name" are to used refer to the file location of the base archive. This is confusing.

          typedef struct GenericCDSFileMapHeader {
           ...
            unsigned int _base_archive_path_offset;
            unsigned int _base_archive_name_size;
          };

      Since most of the implementation uses "name", e.g.,

          FileHeaderHelper::read_base_archive_name()

      We should rename _base_archive_path_offset to _base_archive_name_offset for consistency.

      Attachments

        Issue Links

          Activity

            People

              iklam Ioi Lam
              iklam Ioi Lam
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: