Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8281517

Improve the error message shown when a user tries to install the aarch64 bundle on an intel mac

    XMLWordPrintable

    Details

    • Subcomponent:
    • Resolved In Build:
      b16
    • CPU:
      x86_64
    • OS:
      os_x
    • Verification:
      Verified

      Backports

        Description

        If one incorrectly downloads the JDK aarch64 bundle on an intel mac and tries to install it the error message reads -in the case of 17.0.2- "JDK 17.0.2" can't be installed on this computer.

        It should say instead something like:
        "This installation of JDK 17.0.2 is for arm64 systems. On this computer please download the x64 installer"

          Attachments

            Issue Links

              Activity

                People

                Assignee:
                almatvee Alexander Matveev
                Reporter:
                agarciar Aurelio Garcia-Ribeyro
                Votes:
                0 Vote for this issue
                Watchers:
                9 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: