Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8283076

serviceability/jvmti/vthread/GetSetLocalTest/GetSetLocalTest.java failing in loom repo

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P3
    • Resolution: Fixed
    • Affects Version/s: repo-loom
    • Fix Version/s: repo-loom
    • Component/s: hotspot
    • Labels:

      Description

      This test is failing regularly in the loom repo on macosx-aarch64, typical output is:

      ----------System.out:(39/2210)----------
      Agent_OnLoad started
      Agent_OnLoad finished
      testSuspendedVirtualThreads: started for virtual thread: VThread-Producer
      testSuspendedVirtualThreads: DEPTH > 0
      testSuspendedVirtualThreads: iter: 1
      test_GetSetLocal: test_GetLocal with values0
      test_GetLocal: mounted: 1 depth: 25 fcount: 33
      JVMTI GetLocalInstance succeed for carrier thread top frame Continuation.run()
          local String value at slot 0: msg:
          local Thread value at slot 1: 0x14f80a640
          local int value at slot 2: 1
          local long value at slot 3: 2
          local float value at slot 5: 3.200000
          local double value at slot 6: 4.500000
      test_GetSetLocal: test_SetLocal with values1
      test_SetLocal: mounted: 1 depth: 25 fcount: 33
      testSuspendedVirtualThreads: UNMOUNTED VTHREAD
      testSuspendedVirtualThreads: iter: 6
      test_GetSetLocal: test_GetLocal with values0
      test_GetLocal: mounted: 0 depth: 7 fcount: 15
          local String value at slot 0: msg: 4.500000047683716
          local Thread value at slot 1: 0x14f80a670
          local int value at slot 2: 1
          local long value at slot 3: 2
          local float value at slot 5: 3.200000
          local double value at slot 6: 4.500000
      test_GetSetLocal: test_SetLocal with values1
      test_SetLocal: mounted: 0 depth: 7 fcount: 15
      check_jvmti_status: JVMTI function returned error: JVMTI_ERROR_THREAD_NOT_ALIVE (15)
      FATAL ERROR in native method: get_frame_count: error in JVMTI GetFrameCount call
      at jdk.internal.vm.Continuation.run(java.base@19-loom/Continuation.java:270)
      at java.lang.VirtualThread.runContinuation(java.base@19-loom/VirtualThread.java:217)
      at java.lang.VirtualThread$$Lambda$7/0x000000080104a858.run(java.base@19-loom/Unknown Source)
      at java.util.concurrent.ForkJoinTask$RunnableExecuteAction.exec(java.base@19-loom/ForkJoinTask.java:1428)
      at java.util.concurrent.ForkJoinTask.doExec(java.base@19-loom/ForkJoinTask.java:373)
      at java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(java.base@19-loom/ForkJoinPool.java:1191)
      at java.util.concurrent.ForkJoinPool.scan(java.base@19-loom/ForkJoinPool.java:1634)
      at java.util.concurrent.ForkJoinPool.runWorker(java.base@19-loom/ForkJoinPool.java:1601)
      at java.util.concurrent.ForkJoinWorkerThread.run(java.base@19-loom/ForkJoinWorkerThread.java:167)

        Attachments

          Activity

            People

            Assignee:
            sspitsyn Serguei Spitsyn
            Reporter:
            alanb Alan Bateman
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: