Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8287433

[PPC64] g1_write_barrier_pre needs extension for Loom

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: P4
    • Resolution: Fixed
    • Affects Version/s: 19
    • Fix Version/s: 19
    • Component/s: hotspot
    • Labels:
    • Subcomponent:
      gc
    • Resolved In Build:
      b25
    • CPU:
      ppc

      Description

      Loom requires the c2i_entry_barrier which is currently not supported with G1 on PPC64. (nmethod entry barriers were not needed for G1 before.)

      We run into the following assertion when trying to start the VM with Loom enabled:
      assert(preservation_level <= MacroAssembler::PRESERVATION_FRAME_LR) failed: g1_write_barrier_pre doesn't support preservation levels higher than PRESERVATION_FRAME_LR

      The following frames are on stack:
      G1BarrierSetAssembler::g1_write_barrier_pre
      G1BarrierSetAssembler::load_at
      MacroAssembler::resolve_weak_handle
      BarrierSetAssembler::c2i_entry_barrier

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mdoerr Martin Doerr
              Reporter:
              mdoerr Martin Doerr
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: