Name: sgC58550 Date: 06/27/97
Stack should not inherit from Vector.
Currently we can add items into the middle of the Stack.
Stack should have a Vector as member data, not inherit from it.
Ease of change: trivial
Impact on Java Developers: minor (few people would insert
elements into the middle of their Stacks and if they do,
they should not use the standard Stack class)
Vector should be called Array or Collection
because now I cannot use the name Vector in my
Mathematical applications. Mathematical Vectors are
directed line segments which would have the following
functions: add, getAngle, getIntersection ...
Ease of change: trivial
Impact on Java Developers: large (many people use Vector,
but mathematicians can't)
The abstract class Dictionary should be called AbstractDictionary
so that I can create a Dictionary class which extents HashTable.
Dictionary is much cleaner in application code, Hashtable
is far too computerish.
Ease of change: trivial
Impact on Java Developers: minor (very few people have created
their own subclasses of Dictionary and even if they did it
is a 1 line change in their code)
company - PRIOR , email - ###@###.###
======================================================================