Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-4952781

JComponent.get/setPopupMenu() methods must be renamed

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Fixed
    • Icon: P1 P1
    • 5.0
    • 5.0
    • client-libs
    • b32
    • generic
    • generic



      Name: azR10139 Date: 11/12/2003


      Implementing CCC request 4634626 several methods has been added
      to the JComponent class. But two of them (getPopupMenu and setPopupMenu)
      already defined in a child class - JPopupMenu which causes naming conflict.
      Visible degradation can be detected in any Swing app with JMenuBar by
      right-click on any opened JMenu in JMenuBar. The menu's content will be
      shown as separate popup menu.
      ======================================================================

            kizune Alexander Zuev
            kizune Alexander Zuev
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: