-
Enhancement
-
Resolution: Rejected
-
P4
-
None
-
5.0
-
generic
-
generic
Should all *inherited* methods (static and non-static) be grouped
together as proposed in 4619333:
Methods
Static (non-factory) methods
Instance methods
Inherited methods
or should they be separated?
If not separated, maybe it would suffice to make them stand out (bold?).
Here's a proposal to separate them. They are currently presented
like this:
------------------------------------------------------------------------------
Methods inherited from class java.awt.Container
add, add, add, add, add, addContainerListener, addImpl,
addPropertyChangeListener, addPropertyChangeListener,
applyComponentOrientation, areFocusTraversalKeysSet,
countComponents, deliverEvent, doLayout, findComponentAt,
findComponentAt, getAlignmentX, getAlignmentY, getComponent,
getComponentAt, getComponentAt, getComponentCount, getComponents,
getComponentZOrder, getContainerListeners, getFocusTraversalKeys,
getFocusTraversalPolicy, getInsets, getLayout, getListeners,
getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize,
insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot,
isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout
------------------------------------------------------------------------------
Here they are separated by static: (I didn't bother to actually separate
the proper methods)
------------------------------------------------------------------------------
Methods inherited from class java.awt.Container
static: add, add, add, add, add, addContainerListener, addImpl,
addPropertyChangeListener, addPropertyChangeListener,
applyComponentOrientation, areFocusTraversalKeysSet,
countComponents, deliverEvent, doLayout, findComponentAt
non-static: getAlignmentY, getComponent, getComponentAt, getComponentAt,
getComponentCount, getComponents, getComponentZOrder,
getContainerListeners, getFocusTraversalKeys,
getInsets, getLayout, getListeners, getMaximumSize
------------------------------------------------------------------------------
###@###.### 2005-1-07 01:59:03 GMT
together as proposed in 4619333:
Methods
Static (non-factory) methods
Instance methods
Inherited methods
or should they be separated?
If not separated, maybe it would suffice to make them stand out (bold?).
Here's a proposal to separate them. They are currently presented
like this:
------------------------------------------------------------------------------
Methods inherited from class java.awt.Container
add, add, add, add, add, addContainerListener, addImpl,
addPropertyChangeListener, addPropertyChangeListener,
applyComponentOrientation, areFocusTraversalKeysSet,
countComponents, deliverEvent, doLayout, findComponentAt,
findComponentAt, getAlignmentX, getAlignmentY, getComponent,
getComponentAt, getComponentAt, getComponentCount, getComponents,
getComponentZOrder, getContainerListeners, getFocusTraversalKeys,
getFocusTraversalPolicy, getInsets, getLayout, getListeners,
getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize,
insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot,
isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout
------------------------------------------------------------------------------
Here they are separated by static: (I didn't bother to actually separate
the proper methods)
------------------------------------------------------------------------------
Methods inherited from class java.awt.Container
static: add, add, add, add, add, addContainerListener, addImpl,
addPropertyChangeListener, addPropertyChangeListener,
applyComponentOrientation, areFocusTraversalKeysSet,
countComponents, deliverEvent, doLayout, findComponentAt
non-static: getAlignmentY, getComponent, getComponentAt, getComponentAt,
getComponentCount, getComponents, getComponentZOrder,
getContainerListeners, getFocusTraversalKeys,
getInsets, getLayout, getListeners, getMaximumSize
------------------------------------------------------------------------------
###@###.### 2005-1-07 01:59:03 GMT