Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7123817

jp2ssv.dll, javaws and java control panel do not come from the highest deploy version in the system

    XMLWordPrintable

Details

    • Bug
    • Resolution: Cannot Reproduce
    • P3
    • 7u4
    • 8
    • deploy

    Description

      It is expected that jp2ssv.dll, java web start and java control panel should come from teh highest deploy version in the system, However with the combination of jre 8 and FX runtime 2.0.2, it is not the case. That is, jp2ssv.dll,jp2iexp.dll,javaws.exe, javacpl.cpl are from FX 2.0.2 runtime.
      This is not a regression in the jre 8- DS PIT build as can be reproducible using jre 8-b17 promotion as well


      *** Tested Configurations:
      - x86 XP(sp3), Win 7- UAC on
      - jre 8 PIT DS build
      - jre8-b17 promoted build
      - JavaFX 2.0.2 runtime


      *** Steps to reproduce:
      1) Install jre 8 ( PIT DS build or jre 8-b17 promotion)
      jp2ssv.dll,jp2iexp.dll, javaws.exe and javacpl.cpl come from jre 8 as expected
      2) Install JavaFX 2.0.2 runtime

      Expected: jp2ssv.dll,jp2iexp.dll, javaws.exe, javacpl.cpl should be from jre 8 Which is the highest deploy version in the system
      Actual: jp2ssv.dll, jp2iexp.dll, javaws.exe, javacpl.cpl comes from JavaFX 2.0.2 runtime. Java control panel is launching using deploy.jar from FX 2.0.2 not from jre 8

      Attachments

        Activity

          People

            ngthomas Thomas Ng (Inactive)
            hungnguy Hung Nguyen (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              Imported:
              Indexed: