Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-7155997

RegDeploy: jpi_version in Firefox equals to installed FX plugin version, not to latest installed JRE

    XMLWordPrintable

Details

    • Bug
    • Resolution: Duplicate
    • P4
    • 7u40
    • 7u4
    • deploy
    • b01
    • 7
    • generic
    • windows

    Description

      Desc:
         If JRE + FX 2.1 are installed and FX version is higher ( 6u32 + FX 2.1 b17 ) then jpi_version is 170_04 in about:plugins for FF/GC.
         But application/x-java-applet;jpi_version in registry is "160_32" under MozillaPlugins->@java.com/JavaPlugin,version=10.4.1->MimeTypes

         So if we request 1.6.0_32 via jpi_version applet is not loaded in FF/CG( "need to install plugin" is shown ), although JRE 6u32 is
         installed.

         For 1.6.0_32 classid all works as expected in IE if 6u32 and FX 2.1 are installed.

         See comments for more details.

      Attachments

        Issue Links

          Activity

            People

              ngthomas Thomas Ng (Inactive)
              dgubkin Dmitriy Gubkin (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                Imported:
                Indexed: