Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8016002

Rename periodUntil() to until()

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • P3
    • 8
    • 8
    • core-libs
    • 8
    • b102
    • generic
    • generic
    • Verified

    Description

      The Temporal.periodUntil and ChronoLocalDate.periodUntil methods use the name "period", but we only use that for date-based now via the Period class. The general term is "amount", but renaming to amountUntil() wouldn't be entirely clear. Renaming to until() is simple and effective, and keeps the methods grouped in the IDE.

      See Github issud #311 https://github.com/ThreeTen/threeten/issues/311

      Attachments

        Activity

          People

            rriggs Roger Riggs
            rriggs Roger Riggs
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: