Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8067728

Flag::unlock_diagnostic() should be called Flag::clear_diagnostic()

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 10
    • 9
    • hotspot
    • None
    • b21

    Description

      This method:

      void Flag::unlock_diagnostic() {
        assert(is_diagnostic(), "sanity");
        _flags = Flags(_flags & ~KIND_DIAGNOSTIC);
      }

      doesn't "unlock" anything but clears the "diagnostic" bit so the flag is no longer considered diagnostic. It should be renamed to clear_diagnostic to make that clear and avoid any confusion relating to UnlockDiagnosticVMOptions

      Attachments

        Activity

          People

            rprotacio Rachel Protacio (Inactive)
            dholmes David Holmes
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: