The ObjPtrQueue is strongly tied to the SATBMarkQueueSet, and is only used for SATB support. And with recent changes to the handling of the contents of these queues to support eager reclaim of humongous objects, it is no longer true that the queue elements are always valid oops - they can be stale references to reclaimed humongous objects (and maybe eventually even stale young gen object references). So the present class name and comments about it always containing oops should be changed. SATBMarkQueue would be consistent with the set name.
- is blocked by
-
JDK-8075466 SATB queue pre-filter verify found reclaimed humongous object
-
- Resolved
-
-
JDK-8078023 verify_no_cset_oops found reclaimed humongous object in SATB buffer
-
- Resolved
-