Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8097180

2u Scenebuilder build stuck with signing on Mac OSX with Client jar version



    • Bug
    • Resolution: Fixed
    • P3
    • 8u40
    • tbd_major
    • javafx
    • None


      We need to investigate this 2u Scenebuilder build issue, It is stuck with signing with Client jar version on Mac OSX. Host name is jfx-mac7-mac.

       [copylibs] Copy libraries to /HUDSON/ws/2.u-scenebuilder-nightly/label/macosx-universal/SceneBuilderApp/dist/lib.
       [copylibs] Building jar: /HUDSON/ws/2.u-scenebuilder-nightly/label/macosx-universal/SceneBuilderApp/dist/SceneBuilderApp.jar
           [echo] To run this application from the command line without Ant, try:
           [echo] /HUDSON/ws/2.u-scenebuilder-nightly/label/macosx-universal/scenebuilder-binaries/jdk1.8.0_40.jdk/Contents/Home/bin/java -jar "/HUDSON/ws/2.u-scenebuilder-nightly/label/macosx-universal/SceneBuilderApp/dist/SceneBuilderApp.jar"





          [mkdir] Created dir: /HUDSON/ws/2.u-scenebuilder-nightly/label/macosx-universal/SceneBuilderApp/dist/signed
           [echo] Signing ../SceneBuilderKit/dist/SceneBuilderKit.jar
      Build timed out. Aborting

      -------- Original Message --------
      Subject: Re: Build failed in Hudson: 2.u-scenebuilder-nightly » macosx-universal #18
      Date: Tue, 12 Aug 2014 11:31:22 +0200
      From: Yves JOAN <yves.joan@oracle.com>
      Reply-To: yves.joan@oracle.com
      To: Mong Hang Vo <hang.vo@oracle.com>
      CC: Ajay Gupta <ajay.gupta@oracle.com>

      Hi Mong,

      Below is the status. There's possibly something wrong in the network configuration on the machine, or on the switch it is connected to.

          The two Mac Hudson slaves we use in the US exhibit the same issue, but they used to work like a charm for years. It's only a few weeks ago we started to see the Nightly failing.
          Any other Mac does well (I tried some in France, Ajay tried others in the US).
          Root cause of the failure is the signing: it never returns as soon as the file to sign is big.
          Quoting signing expert, Ajay Gupta:
          "What I see is file is not uploaded from this mac machine due to read time out which is causing this issue. probably timeout for http connection set is too low.
          same file can be signed from any other machine perfectly. From this machine even smaller size file getting signed perfectly. Please check the System settings on this mac."

      I rebooted jfx-mac7-mac, no improvement.
      I checked Network config and saw nothing suspicious.
      I wrote a simple way to reproduce the issue:

          ssh log on jfx-mac7-mac.us.oracle.com (hudson/hudson) or connect using VNC (vnc://jfx-mac7-mac.us.oracle.com)
          cd /Users/hudson/signing
          sh -x signapp.sh ==> it buys you a java process eating 100 % of the CPU and never giving hand back. Signing should be over in a few minutes.

      You'll notice there's also a script named signjar.sh that I've seen failing to give hand back only once ==> smaller is the file to sign higher is the succeed rate.

      Do you know what could have changed on these machines recently, or in the lab where they are ?





            mtvo Hang Vo (Inactive)
            mtvo Hang Vo (Inactive)
            0 Vote for this issue
            3 Start watching this issue