Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8114067

Rename getRowCount to getItemCount in SingleSelectionModel

XMLWordPrintable

      Rename getRowCount to getItemCount in SingleSelectionModel
      Justification: When we first created SelectionModel we had it tightly aligned to the concept of 'rows', but this is incorrect: SelectionModel is being used in many places where 'row' makes no sense. For example, TabPane. A few months back we did a global API replace of references to row with references to index / item, depending on the context. This method was obviously missed, and should be changed to ensure both consistency and clarity when being used in controls that do not have a concept of rows.

            jgiles Jonathan Giles
            rbair Richard Bair (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved:
              Imported: