Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8129959

DebugLogger has unnecessary API methods

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 9
    • 9
    • core-libs
    • b71
    • generic
    • generic

    Backports

      Description

        levelCoarserThan, levelCoarserThanOrEqual, levelFinerThan, levelFinerThanOrEqual, all have confusing names and 3 out of four are unnecessary. We really only need levelFinerThanOrEqual, and since java.util.Logger provides the same predicate under name "isLoggable", we should just rename it as such too and simply delegate to the contained j.u.l.Logger:

            public boolean isLoggable(final Level level) {
                return logger.isLoggable(level);
            }


        Attachments

          Issue Links

            Activity

              People

                attila Attila Szegedi
                attila Attila Szegedi
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved: