Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8080588 VarHandles development
  3. JDK-8154737

Rename VarHandle.compareAndExchangeVolatile to VarHandle.compareAndExchange

    XMLWordPrintable

Details

    • Sub-task
    • Resolution: Fixed
    • P4
    • 9
    • None
    • core-libs

    Description

      Renaming VarHandle.compareAndExchangeVolatile to VarHandle.compareAndExchange makes the naming consistent with compareAndSet (although not with weakCompareAndSet, that currently has "plain" semantics), and is less of a mouthful.

      Attachments

        Issue Links

          Activity

            People

              psandoz Paul Sandoz
              psandoz Paul Sandoz
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: