Migrated the computation of the _java_platform_loader from closed source to systemDictionary.cpp. The _java_platform_loader will be used by the AppCDS code.
In the closed version of SystemDictionaryShared.cpp, we do a lot of comparison of "class_loader() == _java_platform_loader". To avoid duplication of functionality, this usage should be replaced with calls to SystemDictionary::is_platform_class_loader()
In the closed version of SystemDictionaryShared.cpp, we do a lot of comparison of "class_loader() == _java_platform_loader". To avoid duplication of functionality, this usage should be replaced with calls to SystemDictionary::is_platform_class_loader()
- relates to
-
JDK-8189140 SystemDictionaryShared::initialize() should be renamed to be more meaningful
-
- Resolved
-