This method should be renamed to setNotInlinableOrCompilable for better consistency with existing OpenJDK source. Grepping through the sources available from http://hg.openjdk.java.net/jdk10/hs:
dsimon@kruger-4 ~/j/open> ag -i inlineable | grep -v setNotInlineableOrCompileable | wc -l
107
dsimon@kruger-4 ~/j/open> ag -i inlinable | grep -v setNotInlineableOrCompileable | wc -l
24
dsimon@kruger-4 ~/j/open> ag -i compileable | grep -v setNotInlineableOrCompileable | wc -l
3
dsimon@kruger-4 ~/j/open> ag -i compilable | grep -v setNotInlineableOrCompileable | wc -l
585
Based purely on these frequencies, we could rename to setNotInlineableOrCompilable but that looks internally inconsistent (why drop e from one word and not the other?).
dsimon@kruger-4 ~/j/open> ag -i inlineable | grep -v setNotInlineableOrCompileable | wc -l
107
dsimon@kruger-4 ~/j/open> ag -i inlinable | grep -v setNotInlineableOrCompileable | wc -l
24
dsimon@kruger-4 ~/j/open> ag -i compileable | grep -v setNotInlineableOrCompileable | wc -l
3
dsimon@kruger-4 ~/j/open> ag -i compilable | grep -v setNotInlineableOrCompileable | wc -l
585
Based purely on these frequencies, we could rename to setNotInlineableOrCompilable but that looks internally inconsistent (why drop e from one word and not the other?).