There is some confusion in the way we name files containing GC VM operations, i.e.
./runtime/vm_operations.hpp
./runtime/vm_operations.cpp
./gc/shared/vmGCOperations.cpp
./gc/shared/vmGCOperations.hpp
./gc/cms/vmCMSOperations.cpp
./gc/cms/vmCMSOperations.hpp
./gc/parallel/vmPSOperations.hpp
./gc/parallel/vmPSOperations.cpp
./gc/g1/vm_operations_g1.cpp
./gc/g1/vm_operations_g1.hpp
After some discussion, rename them consistently to <gc>VMOperations.?pp.
./runtime/vm_operations.hpp
./runtime/vm_operations.cpp
./gc/shared/vmGCOperations.cpp
./gc/shared/vmGCOperations.hpp
./gc/cms/vmCMSOperations.cpp
./gc/cms/vmCMSOperations.hpp
./gc/parallel/vmPSOperations.hpp
./gc/parallel/vmPSOperations.cpp
./gc/g1/vm_operations_g1.cpp
./gc/g1/vm_operations_g1.hpp
After some discussion, rename them consistently to <gc>VMOperations.?pp.
- relates to
-
JDK-8193312 Rename VM_CGC_Operation to VM_G1Concurrent
-
- Resolved
-
-
JDK-8214850 Rename vm_operations.?pp files to vmOperations.?pp files
-
- Resolved
-