Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8216978

Drop support for pre JDK 1.4 SocketImpl implementations

    XMLWordPrintable

Details

    • b20

    Description

      java.net.Socket and ServerSocket have support for pre JDK 1.4 SocketImpl implementations, specifically to support SocketImpls that were compiled with JDK 1.3 or older, which do not have support for unconnected sockets. This support is legacy. Such implementations do not compile with JDK 1.4 or newer, so it should be relatively safe to drop this support.

      Attachments

        Issue Links

          There are no Sub-Tasks for this issue.

          Activity

            People

              michaelm Michael McMahon
              alanb Alan Bateman
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: