Current G1CollectionSetChooser contains both the collection set candidates (i.e. the set of old gen candidate regions) and the algorithm (and various helper class members) to select these regions from the set of HeapRegions.
That makes the G1CollectionSetChooser quite a bit hard to read. Ideally something like
G1CollectionSetCandidates candidates = G1CollectionSetChooser::select_candidates(...);
would be much easier to read.
Also remove the really hacky use of GrowableArray.
That makes the G1CollectionSetChooser quite a bit hard to read. Ideally something like
G1CollectionSetCandidates candidates = G1CollectionSetChooser::select_candidates(...);
would be much easier to read.
Also remove the really hacky use of GrowableArray.
- duplicates
-
JDK-8217326 Clean up CollectionSetChooser
- Closed
- relates to
-
JDK-8218680 G1 crashes during calculation of old collection set candidates
- Resolved
-
JDK-8218975 Bug in macOSX kernel's pthread support
- Closed
-
JDK-8217328 Rename CollectionSetChooser to G1CollectionSetChooser
- Resolved