Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8222637

Obsolete NeedsDeoptSuspend

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 13
    • 13
    • hotspot
    • b19

    Description

      This code is no longer needed since after JDK 1.5 the register window is always flushed when calling JNI.
      Both code paths work, but one is asynchronous and much more complex.
      A user cannot tell them part, so using +-NeedsDeoptSuspend have no noticeable effect.

      Attachments

        Issue Links

          Activity

            People

              rehn Robbin Ehn
              rehn Robbin Ehn
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: