Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8234574

Rename prediction methods in G1Analytics

XMLWordPrintable

    • gc
    • b26

      In the review for JDK-8227434 the question arose whether the naming of the methods to get predictions in G1Predictions (and wrappers around it) couldn't be improved for readability.

      I.e. change

       get_new_prediction(TruncatedSeq const* seq) const
       get_new_unit_prediction(TruncatedSeq const* seq) const
       get_new_lower_zero_bound_prediction(TruncatedSeq const* seq) const

      to

       predict(TruncatedSeq const* seq) const
       predict_in_unit_interval(TruncatedSeq const* seq) const
       predict_zero_bounded(TruncatedSeq const* seq) const

      Implement this.

            tschatzl Thomas Schatzl
            tschatzl Thomas Schatzl
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: