Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8235757

Rename SupportedGC to IncludedGC

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 14
    • 14
    • hotspot
    • None
    • gc
    • b27

    Backports

      Description

        GCConfig has a concept of a "supported GC". It means the GCs built into the binary. I'd like to add a check to see if a built GC is supported on the current platform, and then there will be a mixup between the two concepts.

        I'd like to propose that we rename it to "included GC", to use the name we use elsewhere:
        #if INCLUDE_ZGC
          zgc code
        #endif

        Attachments

          Issue Links

            Activity

              People

                stefank Stefan Karlsson
                stefank Stefan Karlsson
                Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                  Created:
                  Updated:
                  Resolved: