-
Enhancement
-
Resolution: Fixed
-
P4
-
15
-
b25
G1 currently uses two values to drive heap resizing (expansion):
- recent_avg_pause_time_ratio: contains the (calculated) pause time ratio over the last X mutator/gc phases
- last_pause_time_ratio: contains the (calculated) pause time ratio over the last(*) mutator/gc phase
(*) this is not entirely true, seeJDK-8243672.
I suggest to rename them to long/short_term_pause_time_ratio to be a bit more flexible about the contents.
- recent_avg_pause_time_ratio: contains the (calculated) pause time ratio over the last X mutator/gc phases
- last_pause_time_ratio: contains the (calculated) pause time ratio over the last(*) mutator/gc phase
(*) this is not entirely true, see
I suggest to rename them to long/short_term_pause_time_ratio to be a bit more flexible about the contents.
- blocks
-
JDK-8245087 Use ratios instead of percentages in G1HeapSizingPolicy::expansion_amount
- Resolved