Uploaded image for project: 'JDK'
  1. JDK
  2. JDK-8246837

Rename WeakHandle<vm_class_loader_data> to better reflect its OopStorage association

    XMLWordPrintable

Details

    • Enhancement
    • Resolution: Fixed
    • P4
    • 15
    • None
    • hotspot
    • None
    • b27

    Description

      WeakHandle<vm_class_loader_data> uses the OopStorageSet::vm_weak() OopStorage. This is not obvious from the name. In particular, it becomes problematic when new weak handles are created in other areas of the VM, using the same OopStorage. I don't want them to go under the vm_class_loader_data name, when they have nothing to do with that. It seems more intuitive to name them vm_weak_data, reflecting which OopStorage they are associated with.

      Attachments

        Activity

          People

            eosterlund Erik Ă–sterlund
            eosterlund Erik Ă–sterlund
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: