Details
Description
1. WB_IsJVMTIIncluded function uses runtime check. Most likely compiler elides the check, but for consistency it would be better to implements the function the same way as others:
WB_ENTRY(jboolean, WB_IsJVMTIIncluded(JNIEnv* env, jobject wb))
#if INCLUDE_JVMTI
return JNI_TRUE;
#else
return JNI_FALSE;
#endif
WB_END
2. function names are inconsistent:
isCDSIncludedInVmBuild / WB_IsCDSIncludedInVmBuild
isJFRIncludedInVmBuild / WB_IsJFRIncludedInVmBuild
isC2OrJVMCIIncludedInVmBuild / WB_isC2OrJVMCIIncludedInVmBuild
isJVMTIIncluded / WB_IsJVMTIIncluded
As per David suggestion the functions don't need to have "InVmBuild" in the name as it's redundant/unnecessary
WB_ENTRY(jboolean, WB_IsJVMTIIncluded(JNIEnv* env, jobject wb))
#if INCLUDE_JVMTI
return JNI_TRUE;
#else
return JNI_FALSE;
#endif
WB_END
2. function names are inconsistent:
isCDSIncludedInVmBuild / WB_IsCDSIncludedInVmBuild
isJFRIncludedInVmBuild / WB_IsJFRIncludedInVmBuild
isC2OrJVMCIIncludedInVmBuild / WB_isC2OrJVMCIIncludedInVmBuild
isJVMTIIncluded / WB_IsJVMTIIncluded
As per David suggestion the functions don't need to have "InVmBuild" in the name as it's redundant/unnecessary