ZArray used to be a separate implementation of a dynamically allocated/growable array. It now instead inherits from GrowableCHeapArray, and extends it with a transfer() function. I propose we rename this function to swap() and move it to GrowableArrayWithAllocator, since this function could be generally useful. It would also mean that ZArray could be just a typedef/using of GrowableCHeapArray.
- Per Liden (Inactive)
- Per Liden (Inactive)
- Votes:
-
0 Vote for this issue
- Watchers:
-
3 Start watching this issue
- Created:
- Updated:
- Resolved: