-
Bug
-
Resolution: Unresolved
-
P4
-
8
The javadoc for both AbstractUndoableEdit.undo contains the following:
* ... Subclasses should override to undo the
* operation represented by this edit. Override should begin with
* a call to super.
public void undo()
In the final sentence, the word "override" is used as noun, which is non-standard. A better and clearer way would be: "The overridden method should begin with a call to super."
The javadoc for redo method contains the same sentence.
* ... Subclasses should override to undo the
* operation represented by this edit. Override should begin with
* a call to super.
public void undo()
In the final sentence, the word "override" is used as noun, which is non-standard. A better and clearer way would be: "The overridden method should begin with a call to super."
The javadoc for redo method contains the same sentence.