This is a suggestion:
[~stefank]: I find the VTMT name so obscure that my mind think it is something obscure that I don’t want to learn about. It also doesn’t help that JVMTI has the same letters. Take this as a hint that maybe some expansion of that name would help casual readers of the code. Maybe just expanding the last T to transition would help.
We can try to replace "VTMT" with "VTMS_transition" (VTMS transition stands for "Virtual Thread Mount State transition" ).
[~stefank]: I find the VTMT name so obscure that my mind think it is something obscure that I don’t want to learn about. It also doesn’t help that JVMTI has the same letters. Take this as a hint that maybe some expansion of that name would help casual readers of the code. Maybe just expanding the last T to transition would help.
We can try to replace "VTMT" with "VTMS_transition" (VTMS transition stands for "Virtual Thread Mount State transition" ).